CA BrightStor 11.5 under linux (Arcserve R11.5)

I have tonight install CA Brightstor 11.5, on my Linux servers. I am running Debian so it’s pretty easy; we just need these two files:

/cdrom/cmagent/babcmagt.deb
/cdrom/babagent/babagtux.deb

So it’s just: dpkg –i /cdrom/cmagent/babcmagt.deb
dpkg –i /cdrom/cmagent/babagtux.deb

Then we need to setup the 2 files:
/opt/CA/BABuagent/uagentsetup
/opt/CA/BABcmagt/caagentsetup

Then wee need the agent to start automatic
cd /etc/init.d/
ln –s /opt/CA/BABcmagt/caagent .

Then wee to change something in BABcmagt config fil:
/opt/CA/BABcmagt/agent.cfg
ENV LD_ASSUME_KERNEL=2.4.18
This should be: #ENV LD_ASSUME_KERNEL=2.4.18
update-rc.d caagent defaults
caagent disable all
caagent enable all

If you forget to change this line you get some error about:
12/15 02:47:39(8282) – (_AGBRSpawnSubBrowser), major=11, minor=5 12/15 02:47:39(8283) – (chuid) (root), uid=0, gid=0
12/15 02:47:39(8282) – (_AGBRSpawnSubBrowser): child pid=8283
12/15 02:47:39(8282) – (stcpSend)Failed in send(4), tosnd=8, length=8, Broken pipe
12/15 02:47:39(8282) – (AGBRSendHeader) Failed to send BROWSER_HEADER
12/15 02:47:39(8282) – (_AGBRAppendSubBrowser) Failed in _AGBROpenDir(), ret=-1
12/15 02:47:39(8282) – (_AGBRSpawnSubBrowser): Failed in _AGBRAppendSubBrowser(), ret=-1
12/15 02:47:39(8282) – (uniBrowser) no sub-browser is available

If you are using Ubuntu, please do this also:

If you want to install on Ubuntu (which uses dash as /bin/sh), you need to go through some additional steps.

Go to this page:
http://ubuntuforums.org/showthread.php?t=474790

Download and install getlibs

Right after you dpkg -i the 2 .deb’s, you need to change /bin/sh to /bin/bash in all files in /opt/CA. Then you can proceed as directed above, and all is good.

Thanks to Craig Andrews and Clark Burns, for this Ubuntu trick.

Share this:
Share this page via Email Share this page via Stumble Upon Share this page via Digg this Share this page via Facebook Share this page via Twitter

You may also like...

28 Responses

  1. Jonas PARIENTE says:

    thank you for this post !
    How did you find the trick with LD_ASSUME_KERNEL in agent.cfg file ?

  2. I think it was in a newsgroup somewhere.

  3. Chris says:

    A google search for this error brought me here. Thank you so much.
    I’m sure CA support could have helped me… but I would have had to lie because I’m using an unsupported OS.

    You are awesome!

  4. Craig says:

    If you want to install on Ubuntu (which uses dash as /bin/sh), you need to go through some additional steps.

    Right after you dpkg -i the 2 .deb’s, you need to change /bin/sh to /bin/bash in all files in /opt/CA. Then you can proceed as directed above, and all is good.

  5. admin says:

    Thank you Craig

  6. Anders Gustafsson says:

    Manke takk! Thanks! I have spent a whole day trying to solve this.

  7. Niels says:

    Craig,

    cheers!!!! the env comment did the trick. This was the only place i found this solution!!

    regards,
    Niels

  8. Glenn says:

    Craig,

    With you help I did get the agent to work on ubuntu. The only problem now is I get “Lost connection with server” from Arcserve Manager for windows. Do you have any ideas?

  9. Rik says:

    Great Job!
    I just installed 11.5 on Ubuntu server 8.04 LTS with no problem at all!
    The trick was sh to bash conversion…
    Many thanks to all for your help!!!

  10. Ove says:

    We have some ubuntu (8.04) servers as VMs in VMware.
    I have followed your instruktions but not been able to install Arceserve 11.5. It seems that the SharedComponents directory is not included in the 2 deb’s. What’s happens is that uagentsetup complains about Invalid Uagent Licens (the qlicok returns 127, should be 0).
    Did you install one of the 2 rpm’s (from the Arcerserve Agent CD/ISO) that contains SharedComponents directory in some way? Or do we not need it in the Debian-install?

  11. Ronald Rodriguez says:

    Thank you very much for this POST. It works like a charm.

    Hi from Quito – Ecuador – South America.

  12. Kenneth,

    Many thanks to you for this posting. We just installed Arcserve 11.5 update 4 client agent on a virtual machine running Ubuntu JEOS because your instructions [plus the comments below about /bin/bash] helped us figure out how to do it.

    -yours with abundant gratitude,

    -Steve

  13. Doug Pendergras says:

    Thanks for all the tips!

    I can successfully install and run on my ubuntu 8.04 desktop but not on ubuntu server 8.04.

    caagent enable all
    returns this error..
    /usr/bin/caagent: line 270: /opt/CA/BABcmagt/caagentd: No such file or directory
    /usr/bin/caagent: line 270: /opt/CA/BABcmagt/caagentd: No such file or directory

    any ideas?

    Thanks a million,

    Doug

  14. Clark Burns says:

    First off, thanks for all the help with this!

    Secondly,

    To fix all the above issues related to Ubuntu 8.04 server edition you need to do the following:

    Go to this page:
    http://ubuntuforums.org/showthread.php?t=474790

    Download and install getlibs

    Once installed run getlibs from the command line. Now proceed with the above guide as normal replacing /bib/sh with /bin/bash etc.

    The software is reliant on some 32bit libs when installing on Ubuntu and I’m running 64bit. My guess is the people with issues above are running the 64 bit as well.

    Hope this helps!

    Clark

  15. Scott McIntyre says:

    If you are getting the ‘shell’ related nls erros like this:
    [: 108: /opt/CA/BABcmagt/nls/-e/Messages: unexpected operator
    [: 89: /opt/CA/BABcmagt/nls/-e/Messages: unexpected operator
    [: 642: /opt/CA/BABcmagt/nls/-e/Messages: unexpected operator
    [: 642: /opt/CA/BABcmagt/nls/-e/Messages: unexpected operator
    [: 642: /opt/CA/BABcmagt/nls/-e/Messages: unexpected operator

    I did the quick fix:
    rm /bin/sh
    ln -s /bin/bash /bin/sh

    Now follow Craig’s instructions. This was just much easier to document and maintain then editing each file.

  16. Lajosh Kiss says:

    Thank for your tip! It was very useful.
    Now caagent works with my Fedora 11 and
    Fedora 10.

  17. alx5000 says:

    Hats off to you!

    I finally got it working under Lenny.

    Thank you very much!

  18. Patrick says:

    The env comment did the trick, caagent works now under Suse… Thank you very much!

  19. goodjoy1003 says:

    Thank you this blog fix my problem,thank’s a lot.

  20. Louwrentius says:

    Thanks for the instructions.

    I got “Lost connection with” messages on the manager. I commented out the suggested line in agent.cfg and it worked!

  21. Louwrentius says:

    Thanks a lot.

    It was not working properly using Debian Lenny, but after commenting out that specific line in agent.cfg, it worked.

    Otherwise, I got Lost “connection with” messages on the manager.

  22. Diego says:

    THANK YOU VERY MUCH!
    Is the only web where I found a solution.

    Regards

  23. Roger says:

    Greeting,

    On ubuntu 9.10. I installed the client as instructed above and modified the .cfg.

    In Arcserve manager 11.5SP3 I can view the files in the Ubuntu directory structure but cannot backup them up. I get “Failed to connect with client agent”

    Please advise.

  24. Eric says:

    Thank you, that solved the problem with R15 in debian kernel 2.6.26

  25. Danny says:

    What is the efect of installing getlibs? I’ve tried installing on Ubuntu 10.04 but no luck so far. Are we meant to install the packages with getlibs?

  26. admin says:

    No effect. Just install getlibs package before installation of CA Arcserve

  27. Clay says:

    Awesome. Just fixed my install on OpenSuSe 11 by commenting out the KERNEL line. This is much appreciated!

  28. Gus says:

    In Ubuntu 12.04 64 bits it required to have installed 32 bits libs:

    apt-get install ia32-libs-multiarch

    Here are the commands I run:
    dpkg -i bab*.deb
    find /opt/CA -type f -exec sed -i ‘s/^\#\!\/bin\/sh/\#\!\/bin\/bash/g’ {} \;
    /opt/CA/BABuagent/uagentsetup
    /opt/CA/BABcmagt/caagentsetup
    sed -i ‘s/^ENV LD_ASSUME_KERNEL/#ENV LD_ASSUME_KERNEL/g’ /opt/CA/BABcmagt/agent.cfg
    ln -s /opt/CA/BABcmagt/caagent /etc/init.d/caagent
    update-rc.d caagent defaults
    caagent disable all
    caagent enable all

Leave a Reply

Your email address will not be published. Required fields are marked *