Debian packages cpio failes to be updated

If you have some troubles upgrading cpio, it returns this error:

Preparing to replace cpio 2.6-18 (using …/cpio_2.6-18.1+etch1_i386.deb) …
Unpacking replacement cpio …
Replaced by files in installed package tar …
dpkg: error processing /var/cache/apt/archives/cpio_2.6-18.1+etch1_i386.deb (–u npack):
unable to create `./usr/share/locale/ko/LC_MESSAGES/cpio.mo’: No such file or d irectory
Errors were encountered while processing:
/var/cache/apt/archives/cpio_2.6-18.1+etch1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Try to run this commands:

mkdir -p /usr/share/locale/ko/LC_MESSAGES
mkdir -p /usr/share/locale/gl/LC_MESSAGES
mkdir -p /usr/share/locale/ru/LC_MESSAGES
mkdir -p /usr/share/locale/tr/LC_MESSAGES
mkdir -p /usr/share/locale/sv/LC_MESSAGES
mkdir -p /usr/share/locale/zh_CN/LC_MESSAGES
mkdir -p /usr/share/locale/da/LC_MESSAGES
mkdir -p /usr/share/locale/nl/LC_MESSAGES

And then the update should be working just fine

Share this:
Share this page via Email Share this page via Stumble Upon Share this page via Digg this Share this page via Facebook Share this page via Twitter

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *